SolidWorks 2019 replace child won't stick due to Adept

PeterPPeterP Member Posts: 2
First post, please redirect me if this is the wrong forum.  Apparently you have to be an "Administrator" to get support directly from Synergis?
I am unable to get a replaced part in an assembly model to "stick" in Adept.  I'm using the "replace" command in SW to update a part and all is well in SW references when saved and closed.  Adept never shows the new relationship and always re-opens with the original part. 
I've found the Adept tab relationship refresh button (actually there's two) and have tried several sequences of button pushing w/o success.  I can get as far as the tree showing the new file, but it has a ? in the icon (which I can't find in glyph lists).  Help menu suggests save and close for resetting relationships but that is not working.  Usually I get this error during "Refresh Relationships".
Thanks for any assistance,
Peter

Answers

  • Andrew.HallasAndrew.Hallas Member Posts: 17
    Peter,

    Is the replacement part in the Adept Vault or in your work area? If replacing a part with one in your work area you can use the normal SolidWorks replace component command. If replacing with a file from the Vault you need to use the Adept commands from the Adept TaskPane in SolidWorks.

    After you have replaced the part and saved the assembly file, check the Adept Document Dashboard in the Adept TaskPane or Adept Desktop Client for the assembly file to ensure that the replaced part displays there and doesn’t show a broken reference.





    Andrew Hallas, Design Engineer / CAD Administrator, Bucher Municipal Pty Ltd, Clayton North, Australia
  • PeterPPeterP Member Posts: 2
    Thanks for the reply Andrew.  My Adept Admin and I were able to figure this out after a couple more hours of poking around.  We had to rely on handed down tribal knowledge of an obscure button clicking sequence and hidden menu.
    I was replacing SW assy components that were in my work area by using SW "Replace Component" commands. Adept WI for trouble shooting references only suggested saving and re-opening the file, but this was incorrect.  We found that we had to also go into Adept desktop client and also "Replace Child" or Adept would not let the new child stick. 
    The hard part is this was undocumented (as far as I can tell), and we had to refer to tribal knowledge. The Adept "Replace Chlld" command is perpetually grayed out unless you use special finger gymnastics by holding CTRL+right click.  Not only that, but if you release the CTRL button after getting the "Replace Chlld" command to appear, *you must continue to hold the CTRL button* through all the commands or your clicks will not open the menu window.

    TL:DR: After using SW to replace children you must also use the Adept desktop to repeat the command using a hidden menu.

  • Andrew.HallasAndrew.Hallas Member Posts: 17
    Hi Peter,

    Replacing components via SolidWorks should normally work as the assembly file should get re-extracted when saved. The Document Dashboard gets updated with the new child reference as part of the save process. On a few occasions when it hasn’t worked I then use the ‘Refresh all’ command on the ‘Tools’ menu in Adept Desktop. This will do a re-extract of the SolidWorks assembly file and read the file references and properties and update this data in Adept.

    The ‘Replace Child’ command in Adept Desktop is the main method that we use for replacing components, but it does have its issues. In the past it wasn’t greyed out for SolidWorks files but has been for about the last 5 - 8 years. When this option was changed it was originally turned off permanently for SolidWorks files. I and other companies complained about this and Synergis then added it back with the requirement of holdings down ‘CTRL’ to activate the command. They also said it was up to the user to make sure that the command worked properly for their files as it was causing issues in their testing. It is undocumented or well-hidden in the user guide and Adept help.

    The important thing to understand when using the ‘Replace Child’ command is that the component reference is updated in Adept’s database and not the actual SolidWorks assembly file. When opening the assembly file, Adept is supposed to tell SolidWorks to replace the component when opening but it doesn’t always work properly and the original component gets opened instead. A tip when using the ‘Replace Child’ command is to then use the ‘Batch Open and Save’ command and use the second option in the pull down ‘Save Paths Only (updates reference paths in parents)’. This pushes data into the SolidWorks assembly file for the new component reference.





    Andrew Hallas, Design Engineer / CAD Administrator, Bucher Municipal Pty Ltd, Clayton North, Australia
  • MLubowMLubow Administrator Posts: 21 admin
    Thanks for the interactive problem solving! If you have any other problems you can reach out to the support team at [email protected]
Sign In or Register to comment.